cFos Power Brain als Lademanager für go-eCharger HOMEfix

  • Fragen
  • cFos Power Brain als Lademanager für go-eCharger HOMEfix

cFos Power Brain als Lademanager für go-eCharger HOMEfix

0
0

Hallo,
ich versuche mit einer cFos Power Brain (Firmware 1.24.4) eine Wallbox „go-eCharger HOMEfix 11 kW“ (Firmware 055.8, Hardwareversion V3) in das Lastmanagement einzubinden. Dabei habe ich die Anleitung für die Verbindung via „WLAN mit Modbus TCP/IP“ beachtet.
In der go-e-Wallbox habe ich konfiguriert:
– aktiviert: „Lokale ModbusTCP API erlauben“
– aktiviert: ‚Lastmanagement aktivieren‘
In der cFos-Wallbox habe ich konfiguriert:
a) im Lastmanagement:
– aktiviert: Lastmanagement
b) Neue Wallbox hinzufügen:
– Nummer: 2
– Geräte-Typ: „cFos Power Brain“
– Adresse: 192.168.178.53:502  (192.168.178.53 ist die IP-Adresse meiner go-e-Wallbox)
– ID: 1

Das ist aber nicht erfolgreich. In der Kachel der hinzugefügten go-e-Wallbox wird angezeigt:

Fehler / An
-1 W · · ·
Total: 0 kWh
--------------------------------
E2 / 192.168.178.53:502 / ID 1
��������������������������������,255.255,255.255.35,��������������������������������, Max. 16 A

Nach einer Weile dann zusätzlich:

Com-Fehler: 1 not connected: 192.168.178.53:502 (vor 29 Sekunden)

Ich habe auch versucht, den Geräte-Typ in der Konfiguration der go-eWallbox zu ändern auf „go-e HOME+ mobile“. Die Anzeige lautet dann:

Warten / Aus
0 W · · ·
Total: 0 kWh
--------------------------------
E2 / 192.168.178.53:502 / ID 1
Com-Fehler: 6 (vor 10 Sekunden)

Laut der Liste unterstützter Wallboxen wird die go-eCharger HOMEfix aber von der cFos Power Brain unterstützt.
Ist meine Konfiguration fehlerhaft oder ist die Unterstützung für die go-e-Wallbox aufgrund eines Firmware-Updates verloren gegangen?

markiert als Spam
Geschrieben von (Fragen: 1, Antworten: 4)
Gefragt am 10. Februar 2024
56 views

Antworten (9)

0
Private answer

Tja, da scheint OCPP doch nicht so kompatibel untereinander zu sein.

markiert als Spam
Geschrieben von Top Networker (Fragen: 0, Antworten: 462)
Beantwortet am 10. Februar 2024
0
Private answer

Um die OCPP-Verbindung aufzubauen habe ich jetzt verschiedene Kombinationen getestet:
- für "Adresse" in der cFos-Wallbox:
- CM-03-123456  (wobei ich für 123456 die Seriennummer meiner go-e-Wallbox eingesetzt habe)
- alternativ nur die Seriennummer: 123456

- für "OCPP Server-URL":
- ws://192.168.178.52:19520
- alternativ ohne Portnummer: ws://192.168.178.52

In allen Fällen wird in der cFos zwar kein COM-Fehler angezeigt, aber der Status der Wallbox wird stets angezeigt als  "Offline / Aus". Ich vermute daher, dass die Verbindung fehlschlägt.

markiert als Spam
Geschrieben von (Fragen: 1, Antworten: 4)
Beantwortet am 10. Februar 2024
0
Private answer

Der Port 19520 wäre richtig. Manchmal muss an ihn aber auch weglassen.

In der cFos gibt man als Adresse den Identifikator der Wallbox an. Meistens ist es die Seriennummer oder so etwas.

markiert als Spam
Geschrieben von Top Networker (Fragen: 0, Antworten: 462)
Beantwortet am 10. Februar 2024
0
Private answer

Die Ansteuerung über OCPP hatte ich schon versucht, bislang aber nicht erfolgreich. Meine Einstellwerte waren u.a.:
go-e-Wallbox:
- Internet > OCPP > "OCPP 1.6 aktivieren": aktiviert
- Internet > OCPP > "OCPP Server-URL": ws://192.168.178.52:19520
- Erweiterte Einstellungen > "Lokale HTTP API v1 erlauben": deaktiviert
- Erweiterte Einstellungen > "Lokale HTTP API v2 erlauben": deaktiviert
- Erweiterte Einstellungen > "Lokale ModbusTCP API erlauben": deaktiviert
cFos Power Brain:
- Geräte-Typ: "EVSE with OCPP 1.6"
- Adresse: goeCharger
- ID: 1

Unklar ist u.a., ob in der "OCPP Server-URL" eine Portnummer eingetragen werden muss und falls ja welche.
Außerdem muss in der Konfiguration bei der cFos-Wallbox eine "Adresse" eingetragen werden, ich findet dafür aber kein entsprechendes Feld in der Konfiguration der go-e-Wallbox.

markiert als Spam
Geschrieben von (Fragen: 1, Antworten: 4)
Beantwortet am 10. Februar 2024
0
Private answer

Ja genau, die Kommunikation läuft über die propritäre HTTP-Schnittstelle der go-e-Wallbox. Ob die Einbindung über OCPP auch funktionieren würde weiß ich nicht. Könntest du aber ja mal testen und berichten. :-)

markiert als Spam
Geschrieben von Top Networker (Fragen: 0, Antworten: 462)
Beantwortet am 10. Februar 2024
0
Private answer

OK, das führt tatsächlich dazu, dass der COM-Fehler verschwindet!
Eine funktionierende Konfiguration sieht damit so aus:

go-e-Wallbox:
- Erweiterte Einstellungen > "Lokale HTTP API v1 erlauben": aktivieren
- Erweiterte Einstellungen > "Lokale HTTP API v2 erlauben": kann deaktiviert werden
- Erweiterte Einstellungen > "Lokale ModbusTCP API erlauben": kann deaktiviert werden
- Einstellungen > Lastmanagement > "Lastmanagement aktivieren": kann offenbar auch deaktiviert werden

cfos-Wallbox:
- Geräte-Typ: "go-e HOME+ mobile"
- Adresse: IP-Adresse-der-goe-Wallbox, z.B.: 192.168.178.53 (ohne Portangabe)
- ID: 1

Dazu noch folgende Frage:
Ist es richtig, dass die Kommunikation mit diesen Einstellungen über die propritäre HTTP-Schnittstelle der go-e-Wallbox  läuft; d.h. es funktioniert nur, da der Hersteller cFos sich die Mühe gemacht hat, dieses Protokoll in seinem eigenen Controller einzubauen?
Und könnte die Kommunikation alternativ über OCPP laufen (da beide Wallboxen dieses offene Protokoll unterstützen). Würden über OCPP mehr oder weniger Kontrollmöglichkeiten bestehen?

markiert als Spam
Geschrieben von (Fragen: 1, Antworten: 4)
Beantwortet am 10. Februar 2024
0
Private answer

Kann man auch noch die "Lokale HTTP API v1" in der go-e aktivieren?

Den Port (502) hinter der IP-Adresse weglassen.

markiert als Spam
Geschrieben von Top Networker (Fragen: 0, Antworten: 462)
Beantwortet am 10. Februar 2024
0
Private answer

Danke für die Rückmeldung. Meinst du mit "Http-API aktivieren" die Einstellung "Lokale HTTP API v2 erlauben" in der go-e?

Ich habe in der go-e-Wallbox in den Internet-Einstellungen jetzt konfiguriert:
- Erweiterte Einstellungen > aktiviert: "Lokale HTTP API v2 erlauben"
- Erweiterte Einstellungen > aktiviert: "Lokale ModbusTCP API erlauben"
In der cFos-Wallbox habe ich konfiguriert:
- Geräte-Typ: "go-e HOME+ mobile"
- Adresse: 192.168.178.53:502
- ID: 1

Testweise habe ich auch "Lokale ModbusTCP API erlauben" deaktiviert oder als Adresse nur "192.168.178.53" eingetragen.
In allen Fällen erhalte ich aber leider einen "Com-Fehler".

markiert als Spam
Geschrieben von (Fragen: 1, Antworten: 4)
Beantwortet am 10. Februar 2024
0
Private answer

Hallo,

die go-e wird über die Http-API gesteuert. Dieses muss in der go-e aktiviert werden.

In der cfos gehst du dann eine Wallbox vom Typ go-e an und gibst die IP der go-e an.

markiert als Spam
Geschrieben von Top Networker (Fragen: 0, Antworten: 462)
Beantwortet am 10. Februar 2024